EAimTY 的博客
肥宅。
首页
关于
主题

之前一段时间,本博客一直在用 letsencrypt 的 SSL 证书。这个证书的优点是免费,然而缺点也很明显,就是使用起来比较麻烦,而且有效期只有 3 个月。
我是个懒人,所以能一劳永逸的事,我都会一次性做完。很早之前就了解到 CloudFlare 有免费的 SSL 证书,但是假如仅在 CloudFlare 后台中开启它的话,并不能做到全站加密,只能开启 Flexible 模式,而不是 Full 模式。

进入 CloudFlare 后台 ->Crypto,可以看到第一项就是免费提供的 SSL。
这里有 4 种模式可选:Off(关闭 SSL)、Flexible(视情况而定)、Full(全部加密,需要在服务器上部署证书,但 CloudFlare 不会检查证书的有效性)、Full(Strict)(严格模式,也就是全部加密,而且 CloudFlare 会检查服务器上的证书是否有效)。
在这里,我们的目标是开启 Full 模式,实现方式是:首先自签一个泛域名的证书,然后在 Nginx 中设置通过 HTTPS 访问网站,最后到 CloudFlare 中设置 SSL 模式。
当然,如果你想要开启 Full(Strict) 模式,也是可以的,但服务器上就不能部署自签名的证书了,而需要一个有效机构颁发的证书,例如 letsencrypt 的证书,然而怎么做的缺点就是需要定期续期。

使用自签名证书就不存在这个问题了,你想签多长时间的有效期就可以签多长时间 (我签了 20 年,2333333),更换服务器时,也仅需要把证书文件拷到新服务器上。





注:本主题已经过气,不再被维护,请使用最新的 Materiality

某日,我正在 GayHub 上闲逛,突然发现 Google 竟然有 官方的 material design CSS 库 我真是个火星人
于是,我用这个库把 typecho_material_theme 重写了一遍。

因为是第一版,所以功能还是比较简陋,而且... 说实话,UI 暂时有些...🥴

主题已经上传到了 GayHub 上,旧的主题在bootstrap分支,新的分支是mdl

欢迎提出建议_(:з」∠)_

2018 年 2 月 2 日注:其实升级 Debian 内核的最好方法,就是换用 Debian sid... 省去了很多麻烦,况且 sid 在稳定性上也不算差。

最近用了几天 win10,结果被恶心到了。具体就不说了,总之就是各种各样的垃圾、各种各样的不和谐。

惹不起惹不起,我还是滚回 Linux 吧。

重新回到熟悉的 Debian+Gnome 环境,突发奇想准备升级一下内核。于是折腾了半天,把内核升级到了 4.6.2。
或许是 Debian 8 的默认内核太古老(3.x)(CentOS6 表示不服),也可能是心理作用,感觉 4.x 运行起来的确比 3.x 快了不少,于是手贱直接把旧内核 remove 掉了,而且还加了 purge...(+_+)

但没过多长时间,就发现了问题:VirtualBox 无法启动虚拟机... 查了一下 log,发现原来是 VirtualBox Kernel Modules 出了问题:
VirtualBox Kernel Modules 需要通过 DKMS 使用 linux-headers,而我已经把旧版本的 linux-image 和 linux-headers 都 purge 掉了。然而通过 apt,无论用 testing 源还是 sid(unstable) 源都无法直接安装对应新版本(也就是我装的 4.6.2 版)的 linux-headers 包。

蛋碎一地...Σ(゚Д゚)

通过 Google 到的方法,也就是使用make headers_install,DKMS 仍然报错...
没办法了,重装 Debian...




May 02, 2016

终于把这个一星期前挖的坑填满了... 最近生了点小病,在家里休息了几天

最近,已经用了一年多的手机 HTC Sensation XE 因为太老而开始发病了,具体症状是:触控不定期失灵、信号及不稳定、发热严重、耗电极快、充电极慢... 凑合地用了一个星期,实在是无法忍受了... 考虑到手头实在是不宽裕,于是在狗东买了台 Moto G 2014 LTE (XT1079),准备先用几天。

心中有一万只草泥马在奔腾 ing...

晚上升级了一下 Chrome,顺手把浏览数据清除了。之后进了一下博客,输入网址时没有写 HTTPS,结果发现出问题了:

不通过 HTTPS 访问博客时会被 DNS 劫持!(´Д`)=3

从今天起,eaimty.xyz 及其所有子域名全部启用 SSL 加密,且全部开启 HSTS Preload
顺便在服务器上 yum update 了一下,发现 Nginx 官方 yum 源里的软件包升级到了 1.10,终于原生支持 http2 了, 不容易啊