EAimTY 的博客
肥宅。
首页
关于
主题
您正在查看:2016年6月

2018 年 2 月 2 日注:其实升级 Debian 内核的最好方法,就是换用 Debian sid... 省去了很多麻烦,况且 sid 在稳定性上也不算差。

最近用了几天 win10,结果被恶心到了。具体就不说了,总之就是各种各样的垃圾、各种各样的不和谐。

惹不起惹不起,我还是滚回 Linux 吧。

重新回到熟悉的 Debian+Gnome 环境,突发奇想准备升级一下内核。于是折腾了半天,把内核升级到了 4.6.2。
或许是 Debian 8 的默认内核太古老(3.x)(CentOS6 表示不服),也可能是心理作用,感觉 4.x 运行起来的确比 3.x 快了不少,于是手贱直接把旧内核 remove 掉了,而且还加了 purge...(+_+)

但没过多长时间,就发现了问题:VirtualBox 无法启动虚拟机... 查了一下 log,发现原来是 VirtualBox Kernel Modules 出了问题:
VirtualBox Kernel Modules 需要通过 DKMS 使用 linux-headers,而我已经把旧版本的 linux-image 和 linux-headers 都 purge 掉了。然而通过 apt,无论用 testing 源还是 sid(unstable) 源都无法直接安装对应新版本(也就是我装的 4.6.2 版)的 linux-headers 包。

蛋碎一地...Σ(゚Д゚)

通过 Google 到的方法,也就是使用make headers_install,DKMS 仍然报错...
没办法了,重装 Debian...